Copy track in load menu not working

Home Forums Bug Reports Copy track in load menu not working

This topic contains 4 replies, has 3 voices, and was last updated by Avatar of Raphaël Raphaël 4 years ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #1603
    Avatar of Johan
    Johan
    Participant

    Hi,

    Copying a track from a different pattern in load meny doesnt seem to work.

    What i do:

    1. Enter load menu
    2. Select destination pattern
    3. press and hold track button i want to copy
    4. press source pattern button. The display flashes “copy” briefly, sometimes barely noticable, sometimes a little longer.
    5. Release track button

    But the track remains the same…

    #1609
    Avatar of Christian
    Christian
    Keymaster

    Hi Johan,
    thanks for submitting your bug report!

    Ok, I haven´t heard of this before, seems strange.
    According to your description you are doing the steps right, and the display of “Copy” confirms this. It´s correct behaviour that the display shows “Copy” sometimes a little longer, sometimes shorter, that´s not to worry about. I´ve just tried here again and copying tracks works like described above.

    Can you store the patterns fine normally? If you just store the whole pattern, I mean?
    It´s a prerequisite that the source pattern has content that has been stored there first.

    The only thing I can think of right now (and sorry to ask that), but are you sure that the source track contains the right sequence?

    Also, have you already tried with different patterns and tracks? Is it always the same behaviour?

    Other than that, if all else fails, you could try uploading the firmware again, just to make sure.

    Please keep us posted here!

    #3253
    Avatar of Raphaël
    Raphaël
    Participant

    Hi all,
    I found the bug earlier today. In fact it does work but it recalls the track from the pattern in page 1 and not in the actual page. I tried copying the source pattern to a pattern in page 1 and it worked fine. Also you need to exit the load menu and not press load again of course.
    So I managed to do what I wanted but still there’s a bug.
    Thanks Christian,
    ++

    Raphael

    #3259
    Avatar of Christian
    Christian
    Keymaster

    Hi Raphael,
    thanks for your feedback!

    What Zaquencer version are you on?
    The behaviour you described should actually have been fixed in version 1.02.

    From the changelog:
    Bug Fixes:
    - when copying a track in load menu, would always copy track of page 1 instead of selected page

    Cheers,
    Christian

    #3530
    Avatar of Raphaël
    Raphaël
    Participant

    Hi Christian,
    I had 1.00 !!!
    I’ll fix it.

    Thank you !

    Raphaël

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.