Getting original firmware

Home Forums Support Getting original firmware

This topic contains 8 replies, has 4 voices, and was last updated by Avatar of walter walter 3 weeks ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #5748
    Avatar of Greg
    Greg
    Participant

    Hi, I would like to restore my BCR to it’s original firmware. After some rudamentary searching I couldn’t find any explicit guide on how to do this. Does anybody have a link to a guide and/or can anyone tell me how I would do such a thing? Also if possible, information on how to return the factory presets so that the knobs actually work as they used to!

    any help will be greatly appreciated.

    #5754
    Avatar of Christian
    Christian
    Keymaster

    Hi Greg,
    the original firmware is installed just like the Zaquencer firmware:
    - hold store & load (=”learn” in the original) before and during startup
    - display shows “Load”
    - then transmit the .syx of the original firmware via a midi program like MidiOx, SysEx Librarian or Elektron C6
    - transmission has to be done through the standard Midi Jacks, USB will only become active again once the original firmware is back

    Once the original firmware is back on the device, transmit the preset file via USB like described in the BCR manual (page 18): https://media.music-group.com/media/PLM/data/docs/P0245/BCF2000_BCR2000_M_EN.pdf
    Excerpt: “To receive a SysEx dump, you don’t have to change any settings on your
    equipment. If you send a single preset to the B-CONTROL, the data is written to
    a temporary memory; to be stored permanently, the data has to be stored on a
    storage slot of your choice (preset store function).
    WARNING: If you send an “ALL-Dump” to the B-CONTROL, the entire
    memory contents are directly overwritten! No request to confirm will
    be made, and the memory has no redundant safety function!
    To cancel a SysEx dump, press the EXIT key”
    So, basically you just send the preset file via the same program mentioned above, while the BCR is on and connected/detected as a USB Midi interface.

    Downloads can be found here: https://www.behringer.com/Categories/Behringer/Computer-Audio/Desktop-Controllers/BCR2000/p/P0245/Downloads#googtrans(en|en)

    • This reply was modified 1 week, 1 day ago by Avatar of Christian Christian. Reason: Updated download links
    #5757
    Avatar of Greg
    Greg
    Participant

    followed your instructions and have alleviated my problem! thankyou very much for your time.

    #6099
    Avatar of walter
    walter
    Participant

    Hi, i’ve tried to restore the original firmware with a roland ua-25ex and a roland pcr-M30 following this guide but the bcr2000 display is stucked to LOAD, nothing happen after reboot, it loads the zaquencer fw.. i’ve tried both midiox and EC6, no errors during the transfer. can somebody please help me?

    #6100
    Avatar of Christian
    Christian
    Keymaster

    Hi walter,
    hm this sounds strange. At least the Roland ua-25ex has been reported to work by a user before. Have you installed the Zaquencer firmware yourself with one of those interfaces?
    If it´s stuck on Load it means it doesn´t receive any (correct) Midi data. Is the midi in LED blinking on transmit? At this point the only thing I can think of is the cabling. Please check that you have working Midi cables and, most important that you have connected it the right way (interface out -> bcr in)

    #6103
    Avatar of walter
    walter
    Participant

    Hi,

    i installed the zaq fw few years ago with my edirol pcr-m30 and it worked like a charm ( PUT this BEAST ON THE LIST if you want )

    Now when i try to send sysex file to bcr, the ua25ex interface out led and bcr midi in led both blinking, but nothing happens, stuck on LOAD screen. same issue with edirol : i can see the led on the display sinchronized with the bcr midi in led. i’ve tried 3 midi cables ( 2 Proel Challenge and a Roland RMIDI-B10 ) and they send and receive midi messages well.

    thanks for your time.

    Walter

    #6108
    Avatar of Christian
    Christian
    Keymaster

    Hm, sorry to hear that. Have you tried reinstalling the Zaquencer firmware to see if that gets the BCR to install anything? Other than that I´m afraid I´m out of ideas. Maybe the information in this post helps you (even though the problem sounds a bit different): https://zaqaudio.com/forums/topic/neither-demo-nor-original-zaquencer-works#post-2443

    #6853
    Avatar of mate mr
    mate mr
    Participant

    Hey Walter did you solve this problem? I am having the same issue.

    #6880
    Avatar of walter
    walter
    Participant

    Hey, i have just switched to a brand new M-Audio MIDI­Sport 2X2 AE USB and it worked.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.